Clutch will not enguage?

Reply

  #1  
Old 09-06-07, 09:14 AM
Member
Thread Starter
Join Date: Sep 2007
Posts: 3
Clutch will not enguage?

I have an airens ezr 1540 zero turn with 15 hsp koler engine. Today a wire jumped off of the clutch where it attaches at one of the clutch 's terminals. This has happened a few times in the past and I have attached it and continues running with no problems. Today nothing. I replaced the 2 terminals and wire going into clutch and it still will not enguage when I pull up on the blade enguage knob. In the past you could even hear a clicking sound if you pulled up on the knob when mower was not running..but nothing today. Does anyone know of anything that I might try to see if clutch is still good or something that I could look for or investigate further?
Thanks for any insight.
-John
 
Sponsored Links
  #2  
Old 09-06-07, 09:34 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,822
Unplug the clutch, engage the clutch knob, and check for 12 volts across the wiring connector coming from the mower. If you have voltage there, then you have a clutch problem. If not, a wiring or switch problem. Post with results and we can go from there.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes