Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

12.5 briggs I/C won't start


debo50's Avatar
Member

Join Date: Sep 2007
Posts: 3
NJ

09-07-07, 06:42 AM   #1  
12.5 briggs I/C won't start

I have a MTD 38" riding mower that quit working the other day. It didn't start at all, so I bought a new battery, cleaned all connections and had the starter bench tested. Now it turns over very very slow and the green wire from the ignition switch heats up and smokes. Any suggestions?

 
Sponsored Links
duigoose's Avatar
Member

Join Date: Jul 2006
Posts: 306
FL

09-07-07, 07:17 AM   #2  
Sounds to me like you have a wire not making good connection somewhere. Where does this green wire from the ignition go to?

 
debo50's Avatar
Member

Join Date: Sep 2007
Posts: 3
NJ

09-07-07, 09:59 AM   #3  
The green wire goes from the ignition switch to the ground

 
puey61's Avatar
Member

Join Date: Apr 2004
Posts: 3,224
NY

09-07-07, 12:26 PM   #4  
If the engine quit while operating it then you need to be concerned that the engine might be seized and the starter is causing the start circuit wiring to overheat. How's the engine's oil level and condition? Can you turn the engine over by hand with the spark plug removed from the cylinder head?

 
debo50's Avatar
Member

Join Date: Sep 2007
Posts: 3
NJ

09-09-07, 05:21 PM   #5  
Yes I can turn the motor by hand with the spark plug out. I think I might pull the head to see if the motor is seized or rod broke???

 
Search this Thread