Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

[email protected] 11hp Motor No Spark


theshield09's Avatar
Member

Join Date: Sep 2007
Posts: 3
IL

09-09-07, 12:52 PM   #1  
[email protected] 11hp Motor No Spark

I Have A Rear Engine Riding Mower With A 11 Hp B&s Motor Model 28r707. There Is No Spark Going To The Plug. The Battery,plug,and Magneto Have Been Replaced. Also Sanded The Magnet On The Fly Wheel. Any Ideas??? Thanks

 
Sponsored Links
flirty1's Avatar
Member

Join Date: Dec 2006
Posts: 1,363
MI

09-09-07, 02:30 PM   #2  
can you post back with the riders model number and brand also. sounds like it might be a safety switch problem

 
puey61's Avatar
Member

Join Date: Apr 2004
Posts: 3,224
NY

09-09-07, 03:43 PM   #3  
Isolation of trouble is necessary. Begin by disconnecting the kill circuit wire from the ignition coil (Magneto) at the point that it joins the junction block at or near the speed control bracket (governor). If you have spark at the spark plug after disconnection then you will likely have a safety switch issue and the most likely culprit will be the seat switch. If you have no spark at this point then you have a faulty (bare wire) kill wire running to the coil, assuming the coil you installed is new AND good AND gapped correctly.

 
theshield09's Avatar
Member

Join Date: Sep 2007
Posts: 3
IL

09-11-07, 08:56 AM   #4  
B&s 11 Hp Motor No Spark

THANKS FOR THE INFO.
I REPLACED THE SEAT SAFETY SWITCH AN IT FIRED RIGHT UP. I WOULD OF REPLACED EVERYTHING BUT THE SAFETY SWITCHES AGAIN THANKS!!!!!!!!!!!!!!

 
puey61's Avatar
Member

Join Date: Apr 2004
Posts: 3,224
NY

09-11-07, 12:33 PM   #5  
Fantastic and thanks for updating us on the status.

 
Search this Thread