Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

White GT2150 Blowing Fuses


jasonm4850's Avatar
Member

Join Date: Sep 2007
Posts: 4
MD

09-09-07, 04:12 PM   #1  
White GT2150 Blowing Fuses

I have a 2003 White GT2150 and it has 108 hours on it. It is blowing the main fuse. After replacing fuse, it will start and shortly after that it blows again. I have unplugged the seat switch, still happens, the PTO Clutch, still happens. I checked the battery, wires and all wires for bare wire but nothing. I can smell something burning, it is at the engine, but can not pinpoint exactly where. The starter seems to be operating correctly, as far as engaging, disengaging. The battery light is on on the hour meter though.
Any assistance would be helpful. Local help is very limited.
Thanks
Jason

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

09-09-07, 09:03 PM   #2  
Try unplugging the charging wire(s) and see if the fuse still blows. I'd give more info, but don't know what you have. Anyway, if the fuse stays good, there is a problem with the stator or the regulator if equipped
.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
jasonm4850's Avatar
Member

Join Date: Sep 2007
Posts: 4
MD

09-10-07, 07:48 PM   #3  
Seems OK Now

I just unplugged the Voltage Regulator and started it up. It seems to be running OK and after about 5 minutes no blown fuse. So I guess that it is what was wrong. It just seems odd that only after 109 hours the regulator would go bad. Also any good places to purchase the regulator cheap. My local store wants $85 to order it.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

09-10-07, 10:50 PM   #4  
Check ebay, but the regulators are typically a bit expensive.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread