Craftsman 8HP Running / But...

Reply

  #1  
Old 10-21-07, 11:13 AM
Square Head's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Winnipeg MB, Canada.
Posts: 188
Craftsman 8HP Running / But...

It only runs with the choke fully on, when I take the choke off it dies almost instantly.
What is the govenor settings? It's running way to high of RPM.
The main fuel line must have cracked and sprung a leak as well.
 
Sponsored Links
  #2  
Old 10-21-07, 05:23 PM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
I'm sure you know what you're referring to but we don't. Craftsman 8HP is pretty vague. To answer your governor setting question depends on whether it is a horizontal or vertical crank engine but, always, the governor arm will be adjusted in the same direction that is required for the throttle linkage to obtain full throttle. In other words, if you use a leftward movement of the linkage to obtain full throttle then the governor arm also moves in a leftward movement when adjusting the static setting.
 
  #3  
Old 10-21-07, 05:36 PM
Square Head's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Winnipeg MB, Canada.
Posts: 188
Question Govenor.

Craftsman 8 hp Tecumsee HM80.
It revs way too high. I noticed 2 setting screws under the carb mounting plate. One is attached to a spring(smaller screw) up high. I might have put the linkage to the top of the carb itself in the wrong hole??
 
  #4  
Old 10-21-07, 05:45 PM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
A gentleman who used to frequent this site had a link to Tecumseh service manuals. Anyone out there have the link(s) for the Tecumseh manuals that AZIS used to supply? Square Head, this will help you out greatly in determining the linkage holes you need to use, stay tuned. The two screws in question should be for idle and top RPM settings.
 
  #5  
Old 10-21-07, 06:04 PM
Square Head's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Winnipeg MB, Canada.
Posts: 188
That would be great!!!
The engine seemed to run decent with the choke on. As soon as I turned it off-motor dies?? Too Lean??
I thought the top screw was RPM as well.
I guess RPM needs to be in order before fine tuning the carb?
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 05:33 PM.