Ingersol Tractor not charging battery

Reply

  #1  
Old 11-18-07, 06:45 PM
Member
Thread Starter
Join Date: Aug 2006
Location: usa
Posts: 902
Ingersol Tractor not charging battery

I thought I had a bad battery, but I discovered my Ingersol tractor isn't charging the battery when it is running. What do they use to regulate the battery charge on these units? Any suggestions where to look for the problem? It is a model 4016.
 
Sponsored Links
  #2  
Old 11-19-07, 02:19 AM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
I'm not familiar with a model 4016 Ingersoll tractor but, generally, there will be an alternator under the flywheel producing AC voltage and then, outside the engine and typically attached to the flywheel blower shroud, a voltage regulator/rectifier in order to convert the voltage to DC. The charging wire from here typically goes to the starter solenoid to the post common with the positive cable going to the battery.
 
  #3  
Old 11-19-07, 10:14 AM
Member
Thread Starter
Join Date: Aug 2006
Location: usa
Posts: 902
Thanks. The electrical system is a bit more complicated than it needs to be. There's a voltage detector device, and the output from the rectifier blocks goes back into the ignition switch. I did some metering and I am not seeing any DC coming out of the alternator rectifier block, but I do have AC going in. It appears the diode bridge has opened.

Thanks

Pete
 
  #4  
Old 11-19-07, 11:56 AM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
Sounds like you diagnosed your problem...replace the regulator/rectifier.
 
  #5  
Old 11-20-07, 05:57 PM
CAMINO KID's Avatar
Member
Join Date: Mar 2007
Location: Southern Wisconsin
Posts: 354
I am not sure you have checked everything yet. Before you get voltage out of the rectifier you must have 12 volts from the ignition switch to the center terminal on the rectifier. This 12 volts turns on the rectifier so when you are running the engine you will actually get about 14.4 volts at the center terminal. Most of the units I see coming into my shop have corroded terminals on the ignition switch and sometimes I have to replace the ignition switch before I can get the 12 volts to be supplied to the rectifier. Also look for any connector on the wire lead between the rectifier and the ignition switch checking for corrosion. This is how the three lead rectifier works. Most shops will not take back any electrical part so do a good check before you go for a new rectifier.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes