Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

(Help)Snowblower won't throw snow


skysmith's Avatar
Member

Join Date: Dec 2007
Posts: 1

12-16-07, 12:34 AM   #1  
(Help)Snowblower won't throw snow

I have a Craftsman 9.0 hp snowblower... While snow blowing it just stopped throwing snow. Everything still seems to work, but the augers now are turning pretty slow, the impeller is still at high speed. If the augers(while moving) are slightly touched they just stop turning.

Please help, Thx!

 
Sponsored Links
gary s.'s Avatar
Member

Join Date: Nov 2007
Posts: 24

12-16-07, 04:49 AM   #2  
Posted By: skysmith I have a Craftsman 9.0 hp snowblower... While snow blowing it just stopped throwing snow. Everything still seems to work, but the augers now are turning pretty slow, the impeller is still at high speed. If the augers(while moving) are slightly touched they just stop turning.

Please help, Thx!
Sounds like the gears are stripped in the gear box. I've had that happen before too. Those brass gears & pot metal housings aren't very strong.

 
frankiee's Avatar
Member

Join Date: Jan 2006
Posts: 541
CANADA

12-16-07, 05:21 AM   #3  
While that machine if OFF turn the augers. There are shear bolts that are designed to break if you hit something hard like ice. You may have to look close for the holes where the bolts should be. The bolts are likely gone

 
gary s.'s Avatar
Member

Join Date: Nov 2007
Posts: 24

12-16-07, 11:57 AM   #4  
I forgot about the shear pins. Been there also, that could be the easy fix. Hopefully.

 
Search this Thread