(Help)Snowblower won't throw snow

Reply

  #1  
Old 12-16-07, 12:34 AM
Member
Thread Starter
Join Date: Dec 2007
Posts: 1
(Help)Snowblower won't throw snow

I have a Craftsman 9.0 hp snowblower... While snow blowing it just stopped throwing snow. Everything still seems to work, but the augers now are turning pretty slow, the impeller is still at high speed. If the augers(while moving) are slightly touched they just stop turning.

Please help, Thx!
 
Sponsored Links
  #2  
Old 12-16-07, 04:49 AM
Member
Join Date: Nov 2007
Posts: 24
Originally Posted by skysmith View Post
I have a Craftsman 9.0 hp snowblower... While snow blowing it just stopped throwing snow. Everything still seems to work, but the augers now are turning pretty slow, the impeller is still at high speed. If the augers(while moving) are slightly touched they just stop turning.

Please help, Thx!
Sounds like the gears are stripped in the gear box. I've had that happen before too. Those brass gears & pot metal housings aren't very strong.
 
  #3  
Old 12-16-07, 05:21 AM
Member
Join Date: Jan 2006
Location: Owen Sound Ontario Canada
Posts: 541
While that machine if OFF turn the augers. There are shear bolts that are designed to break if you hit something hard like ice. You may have to look close for the holes where the bolts should be. The bolts are likely gone
 
  #4  
Old 12-16-07, 11:57 AM
Member
Join Date: Nov 2007
Posts: 24
I forgot about the shear pins. Been there also, that could be the easy fix. Hopefully.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes