Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

lawnmower won't start


learnasyougo's Avatar
Member

Join Date: Dec 2007
Posts: 7
AR

12-20-07, 11:46 AM   #1  
lawnmower won't start

I went out to start my lawnmower yesterday to mulch up some leaves and couldn't get it to start. The only thing I noticed different when starting it was my primer bulb wasn't filling up with gas like it use too... I just ran it last week and use fuel stabilizer in it.... Anybody know what the problem is exactly and how to fix it?
It's a Briggs and Stratton - series 10a902 - type 2189-b1 - code 00051755

 
Sponsored Links
geogrubb's Avatar
Member

Join Date: Jun 2006
Posts: 2,333
MO

12-20-07, 04:04 PM   #2  
Remove the air filter and push the primer to see if it is pumping fuel into the engine, if it isn't pour a little gas in the carb and see if it will start, if it does pump fuel, remove the spark plug and ground it to the block and crank the engine to see if you have a spark or you can put a screwdriver in the plug wire cap and crank the engine while holding the metal of the screw driver to see if you get a jolt. Post back as to your progress and we can continue. Have a good one. Geo

 
Legal v8's Avatar
Member

Join Date: Sep 2007
Posts: 239
MN

12-20-07, 04:19 PM   #3  
there are check-valves in the primer and in the pick-up tube in the tank and sometimes either debris or sediment can prevent these checkvalves from operating properly. Make sure the fuel tank is full and do what Geo said and ensure the primer is squirting fuel. If it is not, most likely the check-valve is malfunctioning. If it does squirt fuel but still won't start, then check the spark plug for spark. Let us know what does or doesn't work and we'll try to help.

 
learnasyougo's Avatar
Member

Join Date: Dec 2007
Posts: 7
AR

12-27-07, 02:59 AM   #4  
mower started

I finally got to working on my mower the other day so I decided to try one of your easier suggestions. I made sure the gas tank was full and that fixed it..... Before it was a third full when I tried to prime it and it wouldn't prime. Thanks guys, I'm back in business.

 
Search this Thread