Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Broken pull start handle


sprinter10's Avatar
Member

Join Date: Jan 2008
Posts: 2
ME

01-09-08, 10:29 AM   #1  
Broken pull start handle

I have a 2001 Craftsman 9 HP Tecumseh snowblower. The plastic handle broke off the pull start while trying to start it and the rope, of course, went back through the hole. What do I need to do to replace the handle? Can I just tie a new handle onto the old rope? I'm hoping this will be an easy fix. Thanks for your help.

 
Sponsored Links
flirty1's Avatar
Member

Join Date: Dec 2006
Posts: 1,363
MI

01-09-08, 10:30 AM   #2  
if theres enough rope just thread it through the handle and re-tie it but you will need to re-tighten the spring before putting the handle on.

 
sprinter10's Avatar
Member

Join Date: Jan 2008
Posts: 2
ME

01-09-08, 10:50 AM   #3  
Re-tighten Spring?

Flirty1, thank you for your response, but how do I re-tighten the spring? This seems to be the key to the whole deal. Thanks again.

 
michaeljp86's Avatar
Member

Join Date: May 2005
Posts: 478
MI

01-09-08, 01:21 PM   #4  
Ive done this a million times, Youll have to take the cover off and get to the back side of the spool. I wind the spool up as tight as I can until it stops then let it loose about 3 turns and slide the cord through the hole and put the handle on. When the spring pops off the spool is when the fun starts.

If I was you I would replace the cord, at ace hardware they are like 3 bucks with a new handle.

 
Search this Thread