Yard Machine 10HP snowblower??

Reply

  #1  
Old 02-02-08, 10:19 AM
Member
Thread Starter
Join Date: Feb 2008
Posts: 4
Yard Machine 10HP snowblower??

I was removing snow today, when I realized I ran over the bagged newpapers that were burried on the driveway. Huge snowfall overnight so I didn't see the papers.

Anyway, I have the SB that have the locking auger control, so you can release your left hand while keeping the right engaged and it will continue to throw snow. For somereason that doesn't work anymore. That part that locks looks a little bent.

It waslocked on, so I adjusted it so it would turn off atleast.

Anyway to repair this?? Suggestions, knowledge of diagrams online? I have looked everywhere.

Thanks,
 
Sponsored Links
  #2  
Old 02-02-08, 10:49 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
I don't know about snowblowers, so all I can suggest is trying to bend it back, or replace the bent part. Hang in there, someone with more experience with snowblowers should chime in soon.
 
  #3  
Old 02-03-08, 06:27 AM
Join Date: Jan 2007
Location: MA
Posts: 514
Post your model# and year.
thanks
 
  #4  
Old 02-03-08, 11:31 AM
Member
Join Date: Dec 2007
Posts: 44
Check for ice inside the casing at the base of the clutch handle, that's where the locking latch assembly should be. 90% of the time the problem you describe is caused by ice or impacted snow preventing the latch from locking.
 
  #5  
Old 02-03-08, 01:49 PM
Member
Thread Starter
Join Date: Feb 2008
Posts: 4
Model # is: 31AE6LKG500 -- year:2004

Also, is there anywhere I can see how this is actually supposed to look when it's not bent??

Thanks
 
  #6  
Old 02-07-08, 04:19 AM
Member
Thread Starter
Join Date: Feb 2008
Posts: 4
Well I checked around the latch area and ther is no snow. It looks like the part that engages the lock has shifted and the very bottom part seems to have twisted a bit.

Is there anywhere I can see a picture how this should look? This should give me a clearer picture I hope.

Thanks,
 
  #7  
Old 02-07-08, 04:30 AM
Join Date: Jan 2007
Location: MA
Posts: 514
That model number does not appear to be correct, could you double check it. Also it is a Yard Machines correct?
 
  #8  
Old 02-07-08, 02:20 PM
Member
Thread Starter
Join Date: Feb 2008
Posts: 4
It has Yard Machines on it, but I guess it's made by MTD - this was purchased in Canada.

Model is E6MKH year 2004.

Sorry about that,

Hope this works
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 03:34 PM.