Mantis Tiller run problem

Reply

  #1  
Old 02-21-08, 08:05 PM
Member
Thread Starter
Join Date: Feb 2008
Posts: 1
Mantis Tiller run problem

I have owned a mantis tiller for ten plus years and it is on its 4th set of tines . I purchased a used tiller which was not in running condition , as backup.
I did the usual cleanup, cleaned tank, gas lines and throughly flushed the carburetor. It starts on full choke and will run for a few seconds . At times it will run on full throttle and one quarter choke but quit at any other speed. I took the carburetor off, soaked it in carburetor cleaner and installed a kit. It does essentially the same as before.Help.
 
Sponsored Links
  #2  
Old 02-21-08, 08:31 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Still sounds like a carb problem. Did you verify that all the passages in the carb are clear?
 
  #3  
Old 02-22-08, 12:07 AM
Member
Join Date: Dec 2006
Location: usa
Posts: 1,365
what kind of kit did you install and what did you replace.
 
  #4  
Old 02-22-08, 03:29 AM
Member
Join Date: Nov 2007
Location: NE Okla
Posts: 432
Also, what is the make and model no of the carb and what was the part no of the kit you installed ??
thanks,
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes