toro snowmaster20 problem

Reply

  #1  
Old 03-09-08, 10:00 AM
Member
Thread Starter
Join Date: Mar 2008
Posts: 1
toro snowmaster20 problem

hi i am new to this forum and was wondering if anyone can help me out. i have a toro snowmaster20, it was running fine till recently. everytime i go to start it now it will shut off on me. but if i start it and keep spraying start fluid into it, it will keep running. i am thinking i need a new carburetor, or a rebuild kit. if that is the case can someone point me in the right direction as to where i can purchse one online.

thanx
 
Sponsored Links
  #2  
Old 03-09-08, 10:23 AM
Member
Join Date: Feb 2008
Location: Michigan
Posts: 977
Toro website--go " look up parts "
type model #-find out what engine on your unit.
You can take it from there............
Note: your model # is not s-20
Look at back near bottom of unit for Model #
 
  #3  
Old 03-09-08, 10:32 AM
CAMINO KID's Avatar
Member
Join Date: Mar 2007
Location: Southern Wisconsin
Posts: 354
You will probably want to put a new diaphram and possibly the needle valve and seat in the unit. These are standard tecumshe parts available at most small engine parts stores. I did have an engineer from one of the Japan car manufactures come in and had put the oil in the tank first and then the gas. Pulled the diaphram plate and drained the oil and fuel. Reinstalled and worked fine.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes