Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

MTD Yard Machine Runs Great But Doesn't Like to Start


dc2295's Avatar
Member

Join Date: Aug 2007
Posts: 10

04-23-08, 11:07 AM   #1  
MTD Yard Machine Runs Great But Doesn't Like to Start

Hello,

I aquired a used MTD yard machine from a friend last summer and I have since been having issues with the thing starting. It has a vertical shaft B&S engine in it.

I have to turn the ignition switch on and off several times which only sometimes gets the engine to turn over.

I have since installed the following new parts: battery w/300CCA, starter solenoid, starter motor. I did find a couple areas where the hot and neutral battery cables had touched and melted the wire sheathing together. I separated those wires and wrapped the bare wire in electrical tape.

Any ideas before I run out and buy an ignition switch and sink more money into this tractor? One guy suggested that I check the ground by installing a jumper cable from the negative post of the battery to the chassis (I have not tried this yet).

Thanks!

Dave

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

04-23-08, 11:06 PM   #2  
It does sound like a bad connection, bad solenoid, or bad switch. Do you have a test light?


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
dc2295's Avatar
Member

Join Date: Aug 2007
Posts: 10

04-24-08, 10:21 AM   #3  
Test Light

I can borrow a Fluke meter from work.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

04-24-08, 11:50 PM   #4  
Test for power at the ends of the battery cables instead of at the battery. Then try to start the engine and test for power at the same spots while trying to crank the engine.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread