Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Briggs 15 hp wont start


d.rockinrebel's Avatar
Member

Join Date: Apr 2008
Posts: 1
MS

04-23-08, 01:11 PM   #1  
Briggs 15 hp wont start

I have a Snapper with a Briggs 15 hp intek-we have set the valves checked the keyway-it was not broken- pulled and cleaned the carb-it was not dirty though- we blew through the crankcase filter with no trouble- with the plug out the starter spinn the motor easily- plug in and the engine has so much compression it will not crank pulling the pull rope will almost turn the mower over .It is a2002 model i,ve kept the oil changed ,cleaned the air filter. Put A new plug in too.
Can it be the camshaft?

 
Sponsored Links
repair_guy's Avatar
New Member

Join Date: Apr 2004
Posts: 539
AL

04-23-08, 01:26 PM   #2  
You say that "we have set the valves and with the spark plug in the engine has so much compression it will not crank pulling the pull rope will almost turn the mower over".Ok sounds like the compression release (which is made onto the cam gear) is not working.You need to replace the whole cam gear to fix the problem.Post back with the model & type #'s off the engine shroud and someone can look up the parts (cam&sump gasket) you need.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,565
GA

04-23-08, 11:04 PM   #3  
Are you certain you're following correct procedure to set the valves? This is usually a sign that the valves are not properly adjusted. If they are set correctly, and your starting system is in god shape, then the camshaft may indeed need replacement. I get a lot of them with your symptoms. Adjusting the valves fixes probably 95% or more of them.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread