John Deere STX38 Kohler stalls if I engage PTO or Gear

Reply

  #1  
Old 04-26-08, 08:54 PM
Member
Thread Starter
Join Date: Apr 2008
Posts: 2
John Deere STX38 Kohler stalls if I engage PTO or Gear

I have a John Deere STX38 with Kohler engine. It was not used for two years. I recently pulled it out and did a simple fix (replaced the starter) and it ran fine.

I mowed my lawn twice. At the end of my 2nd mow, I ran out of gas (this is the gas that was stored with the mower for 2 years)

I went out and bought another can of gas. I filled the gas all the way to the top, and started the engine. The engine started fine. No problem there.

BUT..
  1. When I engage clutch to get the mower moving, the engine dies, even at full throttle.
  2. When I engage the PTO switch, the engine dies regardless of anything.
  3. If I put the throttle lever to "choke" position, engine dies.

When the engine is under no load, it runs fine. Sounds fine, no smoke.

What's going on? I recently changed oil/filter/plug/fuel filter/air filter...

Could something have got into carb from the old fuel? I did ran out of fuel (which was in the tank for two years)

Where else do I need to look?
 
Sponsored Links
  #2  
Old 04-26-08, 11:03 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
Sounds like the seat switch went bad, or the connection came loose. Try letting off the clutch with the tranny in neutral. Does it die then? If so, check the seat switch.
 
  #3  
Old 04-27-08, 03:58 PM
Member
Thread Starter
Join Date: Apr 2008
Posts: 2
Indeed.

It was the seat switch. It was already broke off, so I taped it up.. but the tape came loose...

I swear I thought it was some kind of mixture problem or bowl stuck or something going on with the engine.... Nah. The seat switch.

Well it works perfectly, so mowed my lawn this afternoon. Thank you so much.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes