Problems starting a Yard Machines weed trimmer

Reply

  #1  
Old 04-28-08, 08:48 AM
Member
Thread Starter
Join Date: Apr 2008
Posts: 6
Problems starting a Yard Machines weed trimmer

I have a Yard Machines model Y28 weed trimmer made by MTD. I bought it last year at my local Menard's store. I used it for a while and it always seemed a bit hard to pull and hard to start. My brother borrowed it and then later in the season after the droughts had abated I picked it up to use again. My brother then informed me that he hadn't been able to start it for a while and that it needed fixed. I took it home and tried to start it. It seemed even harder to pull than before and didn't seem to be getting fire. I borrowed a trimmer and set it aside. This spring I started looking it over. It gets gas ( spark plugs wet with fuel when I pull it). The plug doesn't seem to be getting fire, even when grounded. However, the plug doesn't seem to be broken or cracked and while a little black from use it doesn't seem to be fouled out either. I checked the gap and it's fine. I checked as many of the electrical connections as I could and nothing seems out of place or broken, to break the circuit. I just can't get it to start. Is there any reason why I shouldn't get fire other than the plug or the wire connections? Does it have anything to do with why it pulls so GD hard? Any help is greatly appreciated.
 
Sponsored Links
  #2  
Old 04-29-08, 09:29 AM
Member
Thread Starter
Join Date: Apr 2008
Posts: 6
I'm still hoping for some help with this. So, BTT.
 
  #3  
Old 04-29-08, 06:09 PM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
The hard pulling could be related to the apparent no-spark problem but it's not likely unless the ignition coil loosened and is making contact with the flywheel. You say that you bought this unit last year. The typical MTD handheld product warranty is one year. Are you within the warranty period? If so, take it to your local MTD service shop for possible warranty consideration. The hard pulling could also be a seizing engine or just the foolish pull assist that most new MTD products incorporate. As for the spark, have you checked for spark at the spark plug by grounding the plug, pulling the engine over and observing for spark at the electrode?
 
  #4  
Old 04-30-08, 08:13 AM
Member
Thread Starter
Join Date: Apr 2008
Posts: 6
I checked the spark plug, by grounding it and pulling, and no spark. It also pulls very easy when the plug is out. I can't find my reciept, but I think that I'm probably outside the warranty period. Could the ignition module possibly be bad?
 

Last edited by Blackpaws; 04-30-08 at 09:56 AM.
  #5  
Old 05-01-08, 01:03 PM
Member
Thread Starter
Join Date: Apr 2008
Posts: 6
Still looking for help on this, BTT.
 
  #6  
Old 05-01-08, 03:36 PM
hopkinsr2's Avatar
Member
Join Date: Feb 2005
Location: canada
Posts: 1,561
You are grounding the plug to the engine & not just a part of the plastic cover??Just to be sure "cus there is a lot of plastic on these. Take the muffler off & look @ the inside of the cylinder & piston (turn the crankshaft slowly to see all of it) incase it started to sieze @ one time....Roger
 
  #7  
Old 05-02-08, 08:05 AM
Member
Thread Starter
Join Date: Apr 2008
Posts: 6
I've grounded it against the block, a screwdriver, and my fingers. Nothing on any of those attempts. I also checked the cylinder and it seems to be moving up and down just fine.
 
  #8  
Old 05-05-08, 07:50 AM
Member
Thread Starter
Join Date: Apr 2008
Posts: 6
I still can't get it to start. I still can't find my reciept to check for warranty. It looks like I'm screwed. I really hate that, since I only used it a few times and and it's somewhere around a year old. It's really crappy that it's already useless, if I can't start it. I really want to figure this out and fix it instead of buying another, especially since I can't afford another right now. I really wish I could habe shelled out a little more and gotten a better made trimmer.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes