Toro Electric Start -- No Charge

Reply

  #1  
Old 05-02-08, 07:07 PM
Member
Thread Starter
Join Date: Jul 2003
Location: Massachusetts
Posts: 5
Question Toro Electric Start -- No Charge

I have a 1 year old Toro Push Mower (Model # 20074) that is not getting any charge to the battery. I thought it was the charger unit, as I was not getting any light at my charge meter in the female end of the charger unit.

Toro sent me a new charger unit, but still nothing. The unit worked well last year, but not now. Changed out the fuse, but this did not help. Any ideas?

I've got about 2 weeks to go before the battery is out of warrenty....

I'll appreciate your ideas of how to proceed....

Greg
 
Sponsored Links
  #2  
Old 05-02-08, 10:41 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
What engine is on it? Have you checked for voltage from the charging coil?
 
  #3  
Old 05-03-08, 02:25 PM
Member
Thread Starter
Join Date: Jul 2003
Location: Massachusetts
Posts: 5
No charger on this push mower -- just a battery that you are supposed to plug in to the electrical outlet every 25 hours.

Worked fine last year, but when I plugged it in this year to charge the battery, I did'nt get any charge. Checked the fuse and it's good. Any ideas how to check whether I'm getting current to the battery?

Perhaps I'll get a voltmeter from work on Monday and check at the male/female plug and at the battery???
 
  #4  
Old 05-03-08, 06:33 PM
Member
Join Date: Feb 2008
Location: Michigan
Posts: 977
Originally Posted by gsnoddy View Post
No charger on this push mower -- just a battery that you are supposed to plug in to the electrical outlet every 25 hours.

Worked fine last year, but when I plugged it in this year to charge the battery, I did'nt get any charge. Checked the fuse and it's good. Any ideas how to check whether I'm getting current to the battery?

Perhaps I'll get a voltmeter from work on Monday and check at the male/female plug and at the battery???
If you did not charge this battery during the winter--you had better contact Toro immed. for a new battery--I had one of
these units--battery freezes & goodbye battery............
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 11:10 PM.