Riding Mower-Goes 20min and stops

Reply

  #1  
Old 05-13-08, 01:52 PM
Member
Thread Starter
Join Date: May 2008
Posts: 2
Riding Mower-Goes 20min and stops

Hi.. new to this forum so sorry if this has been covered... looked at back threads but didn't see anything along this line.

I have a Sears riding mower with a Briggs and Stratton 18HP OHV engine.

This is the problem I'm having:
starts fine when cold
runs well for approx 15-20 min. while mowing
chokes out
cranks again but chokes out under load (i.e. - with mower engaged)
after sitting over night or some long time, it starts and does well again for 15-20 min when the problem repeats itself.

I have tried:
clean air filter
clean oil and oil filter

I am wondering:
could it be the gas?

thank you all for any help... don't want to have to take this to the shop because of expense.... but the grass is growing and i gotta do something sooner rather than later - lol!

thanks!
Carl
 
Sponsored Links
  #2  
Old 05-13-08, 05:42 PM
31YTech's Avatar
Member
Join Date: Feb 2008
Location: EveryWhere
Posts: 1,263
Carl,

Check your gas cap vent and make sure it's not restricted, Engine model and spec numbers could be handy to further diagnose.....
 
  #3  
Old 05-14-08, 04:37 AM
Member
Thread Starter
Join Date: May 2008
Posts: 2
Will do...

Originally Posted by 31YTech View Post
Carl,

Check your gas cap vent and make sure it's not restricted, Engine model and spec numbers could be handy to further diagnose.....
... thanks will check that today and also get back with more info on the engine numbers...
much appreciated
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 12:29 PM.