Deere F525 IGNITION PROBLEM

Reply

  #1  
Old 05-13-08, 09:58 PM
Member
Thread Starter
Join Date: May 2008
Posts: 3
Deere F525 IGNITION PROBLEM

I have a 1996 F 525 and up untill now has never given a bit of trouble. The other day it was running fine and than all of a sudden shut down and wouldn't restart. A few minutes of checking showes that there was no spark. Sparkplug checked out good so I'm guessing coil not very familiar with kawasaki engines. Any ideas
Thanks
 
Sponsored Links
  #2  
Old 05-13-08, 11:35 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,815
What engine is on it? 17hp kawasaki single cylinder air cooled?
 
  #3  
Old 05-14-08, 06:33 PM
Member
Thread Starter
Join Date: May 2008
Posts: 3
Originally Posted by cheese View Post
What engine is on it? 17hp kawasaki single cylinder air cooled?

Hello Cheese,

Yes that's exactly what it has in it, 17 horse power single cylinder air cooled Kawasaki. The decal on the engine says PA540A and from what I could gather from a DEERE website I think the numbers after that are FC540V and the ID number is MOF525A160279.

Thanks Cheese
 
  #4  
Old 05-15-08, 12:16 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,815
Did you try a brand new spark plug?

If so, and still no spark, unplug the kill wire from the white wire near where it plugs into the igniter ont he side of the engine. Check for spark with this disconnected. If there is spark, you have a problem with the wiring or safety system of the mower. If there is no spark still, then you have a bad coil or igniter. I see a lot more kawasaki igniter failures than coil failures. If you do wind up finding a bad igniter, don't go buy a new one from Deere. Buy a genuine Kawasaki igniter. The deere ones are commonly bad right out of the bag, or shrotly thereafter, and they don't take refunds on electrical parts.
 
  #5  
Old 05-17-08, 09:56 AM
Member
Thread Starter
Join Date: May 2008
Posts: 3
Hi Cheese

Tried the new plug and nothing. I will try the igniter next.
Thanks for your help, I'll let you know what happens

Roc
 
  #6  
Old 05-30-08, 08:38 AM
Join Date: May 2008
Posts: 1
Im having the same problem, just looked at it yesterday and no spark. I am going to perform the test you suggested below. I'll let you know what happens.

Also, im doing this repair for my father and do not know much about the mower, the battery died and he jumped it with his truck for like an hour, but it started after he did that. The next time he had to start it though, no spark...
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes