Mcculloch 320

Reply

  #1  
Old 05-22-08, 04:34 PM
Member
Thread Starter
Join Date: May 2008
Posts: 5
Mcculloch 320

I am using this engine on a pedal bike. Put a sprocket on the clutch and use a chain. but anyway. I cant get it started.
I do have spark and I can tell it does have pretty compression by just pulling but I will test it just incase. The fly wheel has not been removed so the timing should be good. Can anyone think of anything else? I am putting gas in the cylinder and pulling but still no go.
 
Sponsored Links
  #2  
Old 05-23-08, 12:15 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Is the chain installed while you're trying to start it?
 
  #3  
Old 05-23-08, 06:31 AM
Member
Thread Starter
Join Date: May 2008
Posts: 5
No, the clutch isnt installed at the momment. I still need to put braze the sprocket on it. I am going to set the timing a little ealier. I once had a weed wacker engine that would not and after setting the timing earlier it ran good. Also I am thinking of making engine mods. DO you know that WONT put blow the engine.
 
  #4  
Old 05-23-08, 01:28 PM
Member
Thread Starter
Join Date: May 2008
Posts: 5
Ok. I can get it running by pouring gas down the cylinder. It wasnt sucking gas through the gas line so i cleaned the carb. It just wont stay running.
 
  #5  
Old 05-23-08, 02:09 PM
Member
Thread Starter
Join Date: May 2008
Posts: 5
Ok. I fooled around with the High and Low settings on the carbs. Runs ok. Little bit of bogging. I found that they rev pretty dam high also. Is this just me?
 
  #6  
Old 05-23-08, 09:38 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
2 strokes rev high. If you have it running too lean, it will rev extremely high and score the cylinder very quickly, ruining the engine. Get it to the highest rpm, and open the H screw a bit until the high speed comes down and the engine gets a bit of a flutter sound to it.
 
  #7  
Old 05-25-08, 09:56 AM
Member
Thread Starter
Join Date: May 2008
Posts: 5
Ok thanks. I also put a lil bit of extra oil in my gas just incase.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes