husqvarna yth150 Hydrostatic shifter hard to slide

Reply

  #1  
Old 05-24-08, 06:17 PM
Member
Thread Starter
Join Date: Dec 2002
Posts: 110
husqvarna yth150 Hydrostatic shifter hard to slide

I have a husqvarna yth150 and the Hydrostatic shifter all of sudden got hard to slide. I can still slide it forward and backwards in to reverse but it feels like it has tension on it like there never has been.
I changed all belts last year and have used it numerous times since then with no problems. Did not notice it last time I mowed but today when I mowed it was very noticable.
Would just like to know what it could be, so maybe I could prevent a problem.
I have owned mower for 6 years and it runs great and still does just the shifter problem.

Thanks for any help!
 
Sponsored Links
  #2  
Old 05-24-08, 09:28 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,820
You might just need to spray a little penetrating oil on the moving parts of the shifter. Sometimes they get a little stiff from the dust and rust. You may find a wad of grass clippings and dirt caked up at the tranny where the shifter connects. If so, clean it up and lube it. You'll also want to clean off the top of the tranny if it is caked up in the cooling fins to keep the unit from overheating.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes