Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Pressure Washer not running


af66's Avatar
Member

Join Date: Jan 2005
Posts: 45
NY

06-01-08, 07:50 AM   #1  
Pressure Washer not running

Hopefully someone was some guidance on this...I'm pretty much out of options here...I have a NorthStar 2100GPM Pressure washer with Comet pump and Honda 5.5HP engine...when taking it out from storage this winter (I had drained the tank) and trying to start it...I had no luck...wouldn't even turn over. So, here's a list of things I've tried:

1: Drained tank again
2: New spark plug
3: disconnected "low-oil" shutoff
4: cleaned out carb (Gumout small engine carb cleaner)
5: cleaned air filter (it was pretty clean to begin with, but just to be sure)
6: adjusted choke and throttle
7: took off fuel line and blew air through it to clear any restrictions
8: checked valves (thought one compression spring might have been stuck, so I worked it free)
9: checked gas cap to make sure it wasn't defective

with all of that done, the symptoms are now that the washer will start only if I spray starting fluid in the air filter, but then after one second it will shut off....then it won't start again unless I spray more starting fluid and the process gets repeated.
If anybody else has some insight or help, I'd appreciate it. Thanks in advance.

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,574
GA

06-01-08, 09:43 PM   #2  
You'll need to clean the carburetor. It's gummed/varnished up inside. Drop the bowl and have a look.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread