Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

troy built tb25et trimmer shaft drive problem


bamahemi's Avatar
Member

Join Date: Jun 2008
Posts: 1
FL

06-02-08, 10:49 AM   #1  
troy built tb25et trimmer shaft drive problem

my trimmer keeps losing connection with the attachment, it started when I could not get the egder attach. to release from the shaft and it pulled the main shaft cable out alittle. I took it apart and tried moving the shaft assemble back towards the engine clutch but when I re-assemble the lower attachment loses connection. I tried adjusting from the end on the trimmer attachment and still have the problem. Any help would be great. The unit runs great and the drive cables are okay I just can't keep the connection together either at the engine, access. connection or at the end of the accessory.

 
Sponsored Links
CAMINO KID's Avatar
Member

Join Date: Mar 2007
Posts: 354
WI

06-02-08, 05:15 PM   #2  
I had several of those units in my shop for service on the same thing. First is these units are sensative to the exact location of the outer housing in relation to the engine and the coupler on the end of the housing where the attachments plug in. There are screws that lock the length of the outer housing and coupler and the engine to the outer housing. One customer had his apart to replace the recoil rope and did not get the drive shaft into the clutch or engine drive properly before he installed the locating screw. Second item I have seen is a spring missing on the drive shaft at the engine. Hope this helps since I will be out of the shop for a few more weeks with rotator cuff surgery.

 
Search this Thread