pressure sprayer - inconsistent pressure

Reply

  #1  
Old 06-12-08, 02:05 PM
Member
Thread Starter
Join Date: Jun 2008
Posts: 1
pressure sprayer - inconsistent pressure

Hi all,
I have an Excell Devilbiss vr2500 6.5 horse pressure sprayer that worked fine a week ago, now no decent pressure. I initially had a clogged nozzle (a little piece of debris) but now looks clean. Engine runs great, but when i pull the trigger, i just a an initial spurt of the pressure i am used to having then it goes into low pressure it seems. If i let go of the trigger, the engine immediately goes into a pressure building sound then cuts back to idle pretty quickly. I pull the trigger again and just the initial spurt of pressure.... I bought a new unloader valve ($40) but no change. The nozzle is in the high pressure position and there are no leaks. I have also confirmed that the gpm is sufficient. This is a link to the breakdown http://www.devap.com/repair_pdfs//PW...FS//vr2500.pdf
What controls the ongoing pressure in the pump? I thought the unloader valve controlled all of this..
Is it possible my wand or nozzle is bad? When I peer through the wand, I see daylight - appears clear but with little partcles on the walls of the tube - didnt think that should be a problem.

thanks in advance.
 
Sponsored Links
  #2  
Old 06-13-08, 12:17 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
I think the unloader is working properly, but you aren't getting the needed volume of water to the pump. Check the inlet screen where the water hose connects and see if it's clogged.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes