Briggs 19 hp v engine electrical problems ?

Reply

  #1  
Old 06-20-08, 04:35 PM
baffledbybriggs's Avatar
Member
Thread Starter
Join Date: Jun 2008
Posts: 1
Briggs 19 hp v engine electrical problems ?

I have a Craftsman 19 hp (Briggs 42A707) lawn mower with a 46" deck....OK here goes_I recently bought this tractor second hand. I used it the day I brought it home, and it hasn't worked since. I knew it needed a battery, so that was the 1st thing I replaced. I know the carb needs work because I have to pour gas into the carb to get it to crank....That's not the problem. The problem is...The starter started smoking(yellow smoke) when I tried jumping it (yes, the cables were hooked up right), So I replaced the starter (ouch $120), The new starter started heating up real fast when I turned on the key. I quickly turned off the key, but the starter continued getting hot. I quickly disconnected the positive cable from the solinoid to the starter, and it was arcing, althought the key was in the off position. Is it the solinoid? Help...
 
Sponsored Links
  #2  
Old 06-21-08, 12:03 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
The starter continued getting hot, but was not turning? It does sound like the solenoid is bad, but it also sorta sounds like your new starter is stuck either because the engine is locked or a starter problem.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes