Murray Lawn Morrer leaking gas

Reply

  #1  
Old 06-27-08, 05:28 PM
Member
Thread Starter
Join Date: Jun 2008
Posts: 2
Murray Lawn Morrer leaking gas

My lawn mower just started leaking gas very bad! Worked well but it up nest week it leaks gas really bad. It is leaking from the prime pump. it pours out a full tank of gas withing an hour of filling it. Any ideas?
 
Sponsored Links
  #2  
Old 06-27-08, 06:31 PM
Member
Join Date: Nov 2005
Location: Illinois
Posts: 112
Check the fuel line and check the carburetor bowl, there should be a bolt that holds the bowl to the carburetor and that might have worked loose.
 
  #3  
Old 06-27-08, 07:29 PM
Member
Join Date: Jun 2006
Location: St. Louis
Posts: 2,365
Post the engine Mfg and model number usually found on the engine shroud just above the spark plug so the gurus will know what they are dealing with. From your description it sound like you have a bowl type carb with the fuel tank above the carb which would indicate the float in the carb has developed a leak and is not shutting off the fuel as intended, so remove the carb, remove the float and shake it to see if it sloshes or set in in some water to see if it sinks, get a new float, reassemble and you are done, while you're getting the new float get a new bowl gasket which is always a good idea when removing the bowl. Have a good one. Geo
 
  #4  
Old 06-27-08, 08:23 PM
Member
Thread Starter
Join Date: Jun 2008
Posts: 2
it Is a B&S 4.5 hp engine there is a plate by the plug that says 12h802-3180-b1 03032859.

I am quite sure that it is a bowl type carb. it is about 5 yrs old. how can i tell for sure if it is a bowl type carb?
 
  #5  
Old 06-28-08, 09:10 AM
Member
Join Date: Jun 2008
Posts: 2
Model 917373580

It only leaks when tilted. The float in the bowl dispurses gas only when inthe down position. It appeared to move up and down freely, thanks
 
  #6  
Old 06-28-08, 09:01 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,813
bejer, it's a bowl carb. Drop the bowl and see if there is trash in it. If so, clean it out, remove the flaot and needle, clean them, and reassemble and see if that fixes the problem.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes