murray riding mower problems

Reply

  #1  
Old 06-30-08, 07:05 PM
Member
Thread Starter
Join Date: Jun 2008
Posts: 3
Red face murray riding mower problems

i have a problem with a murray riding mower 1992 year 40" cut 12.5hp when i try mowing the govenor arm kicks forward and causes the engine to bogg down badly it only does this when i enguage the blades and start mowing anyone have any ideas what the problem is?
 
Sponsored Links
  #2  
Old 06-30-08, 07:47 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,815
Have you checked to see if the blades are stuck (one or both of them)? Sounds like there may be something jammed, keeping a blade from turning.
 
  #3  
Old 06-30-08, 08:11 PM
hopkinsr2's Avatar
Member
Join Date: Feb 2005
Location: canada
Posts: 1,561
Another thing to check are the bearings in the towers & all the idlers along the belt drive system....Roger
 
  #4  
Old 07-02-08, 02:19 PM
Member
Thread Starter
Join Date: Jun 2008
Posts: 3
Thumbs up murray riding mower problems

thanks for the info, i will check the bearings on the deck the blades turn ok when i engage them neither one is stuck but i havn't checked to see how good the bearings are
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes