Briggs Stratton Engine Problem

Reply

  #1  
Old 07-12-08, 09:09 AM
Member
Thread Starter
Join Date: Jul 2008
Posts: 3
Briggs Stratton Engine Problem

Hi all..

I went this morning to cut the grass. I have a B&S 16.5 OHV engine. I started to cut and made a few passes went all of a sudden..it started making a loud noise. When I engage the blades it makes a louder sound. Seems like it's coming from the stack pulley. I believe my blelt is tight enough and my blades move freely. When I put it in gear and take my feet off the brake it barely moves. The idle pulley belt..SEEMS fine.

Please let me know!
 
Sponsored Links
  #2  
Old 07-12-08, 07:05 PM
Member
Thread Starter
Join Date: Jul 2008
Posts: 3
<Bump>

Anyone? I really need help with this...
 
  #3  
Old 07-12-08, 10:40 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,817
What kind of noise is it? Scraping, knocking, squealing, etc...?
 
  #4  
Old 07-13-08, 09:23 AM
Member
Thread Starter
Join Date: Jul 2008
Posts: 3
Originally Posted by cheese View Post
What kind of noise is it? Scraping, knocking, squealing, etc...?
It's kind of like a scraping. Like something needs to be lubed or greased. But I do know it's coming from the stack pulley. When I turn it with my hand, it makes a loud scraping, sqealing sound.
 
  #5  
Old 07-13-08, 04:07 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,817
Sounds like the keyway in the stack pulley is sheared. When you turn the stack pulley, does the engine also turn? If not, the stack pulley needs to be replaced. DOn't run it anymore like this or you'll need a crankshaft too, if not already.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes