Ryobi 725r dies when it gets hot.

Reply

  #1  
Old 07-13-08, 09:28 AM
Member
Thread Starter
Join Date: Jul 2008
Posts: 2
Question Ryobi 725r dies when it gets hot.

It starts & runs fine for 2 minutes. Then it begins to sound muffled and it won't respond to throttling. A second later, it dies and won't restart. What could be the cause of this?
Thanks,
rabo
 
Sponsored Links
  #2  
Old 07-13-08, 04:05 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Check for spark at the plug when it won't start. If there is spark, loosen the gas cap and see if it re-starts.
 
  #3  
Old 07-27-08, 10:58 AM
Member
Thread Starter
Join Date: Jul 2008
Posts: 2
Thanks for the help

I just replaced all the fuel lines. Turns out the old ones had dry-rot. You can't really see that til you remove them, though. I appreciate the feed back.
Rabo
 
  #4  
Old 07-29-08, 06:14 AM
Member
Join Date: Jul 2008
Posts: 1
ryobi 725r

I have a ryobi 725r. I recently replaced the fuel lines, filter and primer bulb. It starts fine and will idle fine but when load is applies it abruptly dies. Any suggestions?>
thanks
 
  #5  
Old 07-30-08, 12:16 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
You probably need to clean the carb.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes