string breaks on elec. weed eater

Reply

  #1  
Old 07-19-08, 11:26 AM
Member
Thread Starter
Join Date: Jan 2008
Posts: 11
Unhappy string breaks on elec. weed eater

When I start my electric weed eater, the string breaks off right where it exits the little hole at the spool. It looks like it's been burned, and is jagged. The hole is jagged and I wonder if filing the hole to smooth it will help. Has anyone else had this problem. It was working fine. Thank for any help. EL in NC
 
Sponsored Links
  #2  
Old 07-19-08, 01:26 PM
30yearTech's Avatar
Member
Join Date: Oct 2006
Location: Central Texas
Posts: 1,176
Most trimmer heads have some sort of metal line saver where the string exits the cutter head. The line saver may have come out of your trimmer head and if so the line will continue to break.

If you have your owners manual, you may want to check and see if there is a parts break down that you can compare to your trimmer head to see if all the parts appear to be in place.
 
  #3  
Old 07-19-08, 03:48 PM
Member
Thread Starter
Join Date: Jan 2008
Posts: 11
Wink weed eater string breaks immediately

I never thought about that. Thanks! I filed the opening and made it smoother, and it worked for quite a while. And then the string starting breaking off again. I am going to look for that book that I'm sure came with it. Thanks. EL in NC
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes