Ryobi 31cc Trimmer Plus won't prime

Reply

  #1  
Old 07-20-08, 11:12 AM
Member
Thread Starter
Join Date: Jul 2008
Posts: 1
Ryobi 31cc Trimmer Plus won't prime

I have a Ryobi 31cc Trimmer Plus (725r) that won't prime. I have drained all the gas to see if when I pump the primer bulb I get air flow, which I do. I then refilled the gas tank, pumped the primer bulb, you can see the bubbles when pushing in on the bulb, but no gas is being sucked in. I put the cap on and primed it, still won't prime. When I remove the cap you can hear the air in the tank escape. Any help would be appreicated. Thanks.
 
Sponsored Links
  #2  
Old 07-20-08, 01:01 PM
Member
Join Date: Jun 2006
Location: St. Louis
Posts: 2,365
Sounds like the fuel lines are bad and need to be replaced. Have a good one. Geo
 
  #3  
Old 07-20-08, 03:35 PM
BFHFixit's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jun 2007
Location: USA.
Posts: 1,836
I have a Ryobi 31cc Trimmer Plus (725r) that won't prime. I have drained all the gas to see if when I pump the primer bulb I get air flow, which I do. I then refilled the gas tank, pumped the primer bulb, you can see the bubbles when pushing in on the bulb, but no gas is being sucked in. I put the cap on and primed it, still won't prime. When I remove the cap you can hear the air in the tank escape. Any help would be appreicated. Thanks.
 

Last edited by BFHFixit; 07-20-08 at 05:57 PM.
  #4  
Old 07-20-08, 05:30 PM
CAMINO KID's Avatar
Member
Join Date: Mar 2007
Location: Southern Wisconsin
Posts: 354
check your fuel line for a crack, especially near and inside the fuel tank. Sounds like you are drawing air and not fuel. You will probably need to replace the fuel lines. LOL
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes