Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

b&s engine only runs when choked


buffdadjj's Avatar
Member

Join Date: Jul 2008
Posts: 5

07-27-08, 04:46 PM   #1  
b&s engine only runs when choked

I have a 3.5 hp B&S 91202 model / type 1016 engine It will only run on choke. Fuel tank and carb are cleaned still no difference. I have not replaced the diaphram yet it still feels flexible.
also how many springs are there on the govener linkage? I think 2 but I found a peice of spring on top of the carb on the shaft throttle that leads me to beleive there may be 3.

And when you replace the diaphram is it spring,cap,diaphram and cover which is the order I took it out or does it go diaphram then cap,spring then cover. I read on another forum that is how it is replaced?

Thanks in advance

 
Sponsored Links
30yearTech's Avatar
Member

Join Date: Oct 2006
Posts: 1,176
TX

07-27-08, 05:18 PM   #2  
Double check your pilot jet and make sure it's open, you may also need to remove the welch plug on the side of the carburetor and make sure all the jets and passages are clear as well.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

07-27-08, 10:24 PM   #3  
The spring goes into the hole in the side of the carb, then the cap, and then the diaphragm. Replace the diaphragm to be sure, even if it is flexible.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
buffdadjj's Avatar
Member

Join Date: Jul 2008
Posts: 5

07-28-08, 11:37 AM   #4  
I put a overhaul kit in today, New gaskets,diaphram,cleaned the carb cleaned pickup tube. still doing the same thing. runs until I turn the choke off. any ideas. I was thinking of maybe getting a new carb. but I feel there is something not right with the govener.

 
wire twister's Avatar
Member

Join Date: Jun 2008
Posts: 486
GA

07-28-08, 12:52 PM   #5  
Are there 2 pickup tubes in the bottom of carb, or just one? One may be laying in the bottom of the fuel tank.

 
buffdadjj's Avatar
Member

Join Date: Jul 2008
Posts: 5

07-28-08, 01:54 PM   #6  
it had a brass tube out of the carb to a plastic tube, I also cleaned out the fuel tank. nothing in there.

 
wire twister's Avatar
Member

Join Date: Jun 2008
Posts: 486
GA

07-28-08, 02:32 PM   #7  
the plastic tube is not split is it?

 
buffdadjj's Avatar
Member

Join Date: Jul 2008
Posts: 5

07-28-08, 03:03 PM   #8  
Ah.that is a good question I will have to check tomorrow.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

07-28-08, 11:57 PM   #9  
If it only runs on choke, it still has a restriction. The plastic tube being split wouldn't cause this but it doesn't hurt to check the tube while you have it off.

I'd get it running before worrying about the governor. The governor isn't causing the problem you're having at the moment. Once it's running, if it has governor problems, it will become evident then.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
buffdadjj's Avatar
Member

Join Date: Jul 2008
Posts: 5

07-30-08, 01:03 PM   #10  
Got it running I guess I did not clean the carb well enough. soaked it for a while and cleaned it real well purr's like a kitten now. Thanks everyone for your help!

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

08-01-08, 12:56 AM   #11  
Glad you got it. Thanks for the update!


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread