Poulan HD145H42J, 14.5 lawn tractor

Reply

  #1  
Old 07-29-08, 07:04 PM
Member
Thread Starter
Join Date: Jul 2008
Posts: 9
Poulan HD145H42J, 14.5 lawn tractor

Runs good for 15-20 minuets.then looses traction going uphill and does not go in reverse.On plane ground mows OK in forward.Changed drive belt, changed transmission oil.Ran while jacked up in reverse and forward for 15 minuets. Still the same. What should I do.
 
Sponsored Links
  #2  
Old 07-29-08, 11:53 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Is there a lot of grass built up on top of the transmission?

What color was the oil you drained from it?

Do you pull anything with it?
 
  #3  
Old 07-30-08, 03:28 PM
Member
Thread Starter
Join Date: Jul 2008
Posts: 9
Poulan HD145H42J, 14.5 lawn tractor

Originally Posted by cheese View Post
Is there a lot of grass built up on top of the transmission?

What color was the oil you drained from it?

Do you pull anything with it?
No there is no grass built up.

Oil was of light Grey color.

Never pulled anything with it
 
  #4  
Old 08-01-08, 12:51 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
The grey color is because of aluminum in the oil. Time for a tranny.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes