Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Craftsman riding mower-battery draining


mooonchild's Avatar
Member

Join Date: Aug 2008
Posts: 1

08-04-08, 05:27 PM   #1  
Craftsman riding mower-battery draining

I was having to jump my Craftsman riding mower to get it started, and the battery would not recharge. Took the battery to test at AutoZone, and it was bad. Bought a new battery, mower cranked up perfectly. Ran for about 20 minutes, stopped to move something out of the way, tried to restart, and it would not crank. Have checked all the connections to make sure everything is tight. All safety switches, deck, seat, etc. are okay. I can jumpstart the mower, but the battery does not recharge while mowing.

Suggestions?

 
Sponsored Links
rogerflies's Avatar
Member

Join Date: Jun 2008
Posts: 150
GA

08-04-08, 11:35 PM   #2  
Check the fuse in the wire between the keyswitch and the starting solenoid. If it's blown, the battery won't charge and the none of the electrical system will work.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

08-05-08, 12:25 AM   #3  
I don't know what you have. Got model #s? Kohler engine? If so, look under the dash area for 3 relays. One of these is related to charging and if it fails, it will not allow the engine to charge the battery. There are checks that can be done to determine the source of the problem, depending on what you have.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread