Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

John Deere Gt275


dmbtpa's Avatar
Member

Join Date: Aug 2008
Posts: 1

08-10-08, 02:04 PM   #1  
John Deere Gt275

the blades no longer engage when I pull the knob? (fuses are OK)? Any help would be appreciated.

Thank you

 
Sponsored Links
30yearTech's Avatar
Member

Join Date: Oct 2006
Posts: 1,176
TX

08-10-08, 07:27 PM   #2  
First thing to do is check and make sure the drive belt is on the clutch pulley and mower deck.

Neck check to see if your getting power to the clutch when you engage the pto switch. If you follow the wires from the electric clutch on the bottom of the engine you will find a plug, disconnect the plug and using a 12volt test light or multimeter, turn the key on and activate the blade switch, you should have power at the plug. If you have no power you will need to trace back through the pto switch to find out where the current stops.

IF you have power to the clutch, then the clutch may need to be adjusted or the clutch may need to be replaced.

 
CAMINO KID's Avatar
Member

Join Date: Mar 2007
Posts: 354
WI

08-11-08, 05:59 PM   #3  
I had the same tractor for 12 years and the last year before I sold it, the PTO switch went bad. When you pull the plug off the back of the PTO switch do not confuse the safety wiring with the power feed. The seat switch works with the PTO switch so that if the nobody is on the seat the tractor will stall. On my switch the feed did not come out of the switch to feed the clutch. GOOD LUCK.

 
Search this Thread