Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Husqvarna 20HP Kohler Rider No Start Issue


Andy English's Avatar
Member

Join Date: Aug 2008
Posts: 1

08-11-08, 10:57 AM   #1  
Husqvarna 20HP Kohler Rider No Start Issue

I have a late 90's model Husqvarna riding mower with a 20 HP Kohler motor. Twice witin the last 2 weeks when trying to start the mower with good charge, the sarter and solonoid just make a dull click noise, i crossed the solenoid with a screw driver and still nothing, just the heavy click noise in the solenoid and the starter will not engage. When this occurred the fist time I inadvertently moved the red starter cable and the mower started, i double checked this connection and the connection was nice and tight. Any help would be much appreciated, the local Husqvarna repair shop is booked two weeks out.

 
Sponsored Links
rogerflies's Avatar
Member

Join Date: Jun 2008
Posts: 150
GA

08-11-08, 05:38 PM   #2  
It doesn't take much corrosion to keep the connection from passing the current needed for starting the engine. Having it start when you moved the wire is a sure sign the connections are causing problems.

It would probably be a good idea to take each connection apart, clean the terminals and contact surfaces with a stiff wire brush, and tighten them back up. You can get special grease to put on the connections to keep them from getting corroded, too.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,564
GA

08-11-08, 10:29 PM   #3  
I'd be inclined to think the solenoid itself is bad if the cable connection is clean and tight. Moving the wire may have been just enough movement at the solenoid to jar it loose so that it could crank again, or sometimes solenoids work once and not again for 20 tries or so, only to suddenly work again (no rhyme or reason).


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread