YTD Yard Machine Won't Move

Reply

  #1  
Old 08-20-08, 10:16 AM
Member
Thread Starter
Join Date: Aug 2008
Location: Virginia
Posts: 4
YTD Yard Machine Won't Move

As I was finishing my yard (thankfully) my MTD Yard Machine Model 675 stopped moving. Engine runs, blade turns, mower won't go. The brake/clutch pedal seems to be abnormally close to the rider. Any "no brainer" places to start before I start tearing this puppy apart?
 
Sponsored Links
  #2  
Old 08-20-08, 11:52 AM
Member
Thread Starter
Join Date: Aug 2008
Location: Virginia
Posts: 4
Ooops, the full model number is 13AM675G062 and the serial number = 1B121B40210 if that helps at all.
 
  #3  
Old 08-20-08, 11:58 AM
Member
Join Date: Feb 2008
Location: usa
Posts: 755
Check the drive belt and pulleys. Drive belts are often the culprit. If those are good post back.

If you do not have an owners manual get one here.
http://manuals.mtdproducts.com/mtd/p...randCode=10201
 
  #4  
Old 08-20-08, 09:31 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,815
I agree...almost certainly a drive belt has come off or broken.
 
  #5  
Old 08-22-08, 06:17 AM
Member
Thread Starter
Join Date: Aug 2008
Location: Virginia
Posts: 4
Thanks, It appears that it was indeed a belt. It wasn't broken (that's what threw me, I didn't see any belt remnants, and the darn thing is so high I couldn't see it) but after opening the beast up, I see that it has deteriorated and there are chunks gone so I'm sure it's probably 10% larger than it should be. I've order new belts (I'm replacing the other one while I'm in there) so you MAY be hearing from me again when they arrive !LOL!
 
  #6  
Old 09-03-08, 08:16 AM
Member
Thread Starter
Join Date: Aug 2008
Location: Virginia
Posts: 4
Just a note of thanks... with the aid of the owners manual.. changed both drive belts and mower's working fine now.
 
  #7  
Old 09-03-08, 07:53 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,815
Good news! Thanks for the update, and glad you got it going!
 
  #8  
Old 03-23-09, 10:47 AM
Member
Join Date: Mar 2009
Location: Michigan
Posts: 1
I have a yard machine 17 hp. Problem 1. It will start if you jump it with jumper cables but if you turn it off and then try to start it on it's own it won't even turn over at all. I had the battery checked and it is ok. This is very annoying if for some reason it stalls.
2nd Problem to drive the mover you have to hold down the shifter in the forward position the hole time or the mover won't go. So you need 2 hands to cut the grass. (one to steer, one to make it go forward)
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes