17.5 tecumseh trouble

Reply

  #1  
Old 08-31-08, 11:29 AM
Member
Thread Starter
Join Date: Jul 2008
Posts: 4
Unhappy 17.5 tecumseh trouble

17.5 tecumseh on a murry riding mower. ran out of gas and it ran fine for about 10 minutes, then it started backfiring and cutting out. put sea foam cleaner in gas and changed the spark plug. let it set overnite to let the cleaner do its work but still the same. So I pulled the carb off cleaned, and blew it out with air hose, put it back and still the same. think a carb kit might fix or maybe a new carb. any ideas on anything else that it might be. thanks
 
Sponsored Links
  #2  
Old 08-31-08, 01:00 PM
chandler's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Dec 2005
Location: USA
Posts: 39,968
It sounds like a problem with the key on the crank being partially sheared. Pull the flywheel and renew the key in the slot. I think you will find the timing off, and/or the armature rusted slightly. Seldom will fuel alone cause backfiring. Let us know how it goes.
 
  #3  
Old 08-31-08, 11:18 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Is there any smoke coming from the exhaust at the time of backfiring/running badly?
 
  #4  
Old 09-01-08, 09:00 AM
Member
Thread Starter
Join Date: Jul 2008
Posts: 4
no smoke coming from the exhaust. I pulled the breather filter off and did notice that it is also coming out of the carb, but not at the same time. one time out of the exhaust and the next time or two out the carb.
 
  #5  
Old 09-01-08, 02:18 PM
Member
Thread Starter
Join Date: Jul 2008
Posts: 4
probably need new carb. went back to check it again and the cylinder was full of gas and so is the crank case. so I will drain them and try to find a new carb.
 
  #6  
Old 09-02-08, 12:25 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
That should fix it..................
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes