Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Briggs 18.5 hp Intek problems


Partsman 103's Avatar
Member

Join Date: Aug 2008
Posts: 3

09-01-08, 09:59 AM   #1  
Briggs 18.5 hp Intek problems

I have a John Deere L108 with an 18.5 hp single engine B&S engine. It developed a running problem after warming up, and acted just like a coil breaking down. Tried two aftermarket coils and went back to a factory Briggs coil. When the engine starts cutting out, I can pull the fuel ine off of the carburetor and there is plenty of fuel flow. I have changed the spark plug, fuel filter, drained and cleaned the tank, and checked all electrical connections and grounds. There is an electic solenoid on the bottom of the float bowl that has battery supplied voltage when on and reads charging system voltage when running. Has anyone heard of these breaking down when hot?

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,570
GA

09-02-08, 12:36 AM   #2  
Never heard of one doing that.

I would pull the carb bowl off and clean it out...thinking there may be trash/rust in it.

Also, check the kill wire to the coil. Make sure it isn't pinched behind the starter. Often times, they get pinced between the starter and engine block and work ok untilt he engine gets hot and the insulation of the wire gets softer and the wire begins to leak across and short to the engine, causing popping, sputtering, and usually eventually kills the engine.

Don't use aftermarket coils...I don't think I ever got a good one that lasted.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread