Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Ryobi 790R "EZ" Trimmer won't stay running


pyroman's Avatar
Member

Join Date: Sep 2008
Posts: 2

09-07-08, 04:57 PM   #1  
Ryobi 790R "EZ" Trimmer won't stay running

I could really use your knowledgeable assistance with a problem I am having with my Ryobi trimmer. I all started about 2 months ago when the primer bulb cracked on my Ryobi 790r trimmer with 31cc motor w/Zama carb. I ordered the correct replacement primer bulb assembly from Ryobi and also took the opportunity to replace the foam carb. filter.
After replacing these things the unit started and ran, but will not run on anything past the middle choke setting (1/2 choke). When I remove the choke completely or any more than 1/2 the motor stalls. I have checked the air filter (even tried running without the element in place), cleaned the muffler/arrestor, and checked the fuel lines. I is almost like it is not getting enough fuel since it stalls when the air port is opened more than 1/2 way. The two carb adjusting screws appear to still be in their factory set "middle" setting based on the two plastic screw caps that are on the adjustment screws. The screw closest to the head is yellow and the one closet to the air filter is red.
Any ideas what I need to do???? Thanks, J

 
Sponsored Links
30yearTech's Avatar
Member

Join Date: Oct 2006
Posts: 1,176
TX

09-07-08, 07:05 PM   #2  
Try opening the adjustment screw with the red cap as far as you can and see if that helps any. From your description, it sounds like your not getting enough fuel and opening up the adjustment may take care of it. There is also a possibility that the carburetor may need new diaphragms or a rebuild kit.

 
flalles's Avatar
Member

Join Date: Mar 2009
Posts: 1

03-30-09, 08:05 AM   #3  
i have a 790r 31cc trimmer engine and it wont stay running unless im priming it i replaced the fuel lines and spark already what do i do?

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,570
GA

03-30-09, 08:18 PM   #4  
Sounds like the carb needs to be taken apart and cleaned.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread