Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

onan generator no output


NAVYDAD's Avatar
Member

Join Date: Jul 2006
Posts: 81
TX

09-26-08, 11:15 AM   #1  
onan generator no output

can anyone tell me where or what to look for. the engine runs good and I have tried the flash field test and nothing happens. I feel current on the drill that I have connected ,but it seems that it is not enough to turn it on.

 
Sponsored Links
liljman's Avatar
Member

Join Date: May 2008
Posts: 105
FL

09-26-08, 12:02 PM   #2  
if you can, look on the id tag and post the model/spec #. please

 
NAVYDAD's Avatar
Member

Join Date: Jul 2006
Posts: 81
TX

09-26-08, 04:58 PM   #3  
liljman,I'LL get it for you I'm sorry about that, it's that I really want to make this work if I can,I'll post back with the info.

 
NAVYDAD's Avatar
Member

Join Date: Jul 2006
Posts: 81
TX

09-29-08, 11:35 AM   #4  
liljman,Here is the model info ONAN K2200 MODEL=2.2KM-1P/1B POWER EXPRESS pelase help

 
Speedwrench's Avatar
Member

Join Date: Apr 2008
Posts: 1,698
OK

09-29-08, 12:36 PM   #5  
navydad have you used a voltmeter on any of the outlets yet?

murphy was an optimist

 
flirty1's Avatar
Member

Join Date: Dec 2006
Posts: 1,363
MI

09-29-08, 12:49 PM   #6  
Posted By: NAVYDAD can anyone tell me where or what to look for. the engine runs good and I have tried the flash field test and nothing happens. I feel current on the drill that I have connected ,but it seems that it is not enough to turn it on.
have you tryed other items or tested the drill on a working outlet. maybe the drill is bad.

 
NAVYDAD's Avatar
Member

Join Date: Jul 2006
Posts: 81
TX

09-29-08, 06:05 PM   #7  
speeedwrench, I'll try the voltmeter and see what I get off it .and also flirty1 the drill does work I tried it on a house socket.it has a trip switch and other breaker attachments.Do you know where I could try to check for current on a good starting point and catch the problem half way.

 
Speedwrench's Avatar
Member

Join Date: Apr 2008
Posts: 1,698
OK

09-29-08, 06:35 PM   #8  
i just use the voltmeter in the outlets to check for correct voltage, i am not sure but your gen might have brushes, if so you might need to check that they are free to move in the holders and not worn out. you can clean with spray electrical contact cleaner to help free them up if they are sticking in the holders.

if we're not supposed to eat animals why are they made out of meat?

 
NAVYDAD's Avatar
Member

Join Date: Jul 2006
Posts: 81
TX

09-30-08, 06:38 AM   #9  
speedwrench ,Do I open the housing where the coils are at to get to the brushes?The heart of the generator?Can I unbolt it and remove the guts out to expose the brushes?

 
liljman's Avatar
Member

Join Date: May 2008
Posts: 105
FL

09-30-08, 08:37 AM   #10  
navydad, sorry so-long to get back to you, I have a complete library of onan service manuals and would love to help you out, however I find nothing on the info that you have given me...
it could be anything from bad brushes, commutator, or something as simple as a circuit board replacement.
is this a portable unit? rv-genset?,
example mod & spec # NHD, NH, BGM, CCK,. if you can find something similar on your id tag I'll help ya any way I can...

good luck and have a great day

 
Gunguy45's Avatar
Super Moderator

Join Date: Dec 2007
Posts: 20,666
AZ

09-30-08, 09:21 AM   #11  
hey liljman...does this help you find anything to help NAVYDAD?

Just take a look at the link.

http://cgi.ebay.com/ONAN-K2200-GENER...ayphotohosting


Vic
"I sometimes wonder how some people ever made it to adulthood..."

 
NAVYDAD's Avatar
Member

Join Date: Jul 2006
Posts: 81
TX

09-30-08, 10:46 AM   #12  
liljman,Tell Me what info You need and i'll look for it on the generator and Yes it is a portable generator with a kohler engine.Also thank Gunguy45 for the help

 
NAVYDAD's Avatar
Member

Join Date: Jul 2006
Posts: 81
TX

10-12-08, 08:54 AM   #13  
ok , I finally had some time to mess with the generator,And I turned on the engine and found out I have 12.5 volts coming out of the socket.Not enough to turn anything on .I also found it does have brushes .They are not to bad ,some formation to the direction it is turning.I also as the engine is running I have the volt meter connected and I switch the circuit breaker to the off postion and it drops to 1.5 from the socket reading.liljman, I found this #'s on the generator side model# NA18E1 also NO#3IM017 PLEASE HELP

 
Search this Thread