onan generator no output

Reply

  #1  
Old 09-26-08, 11:15 AM
NAVYDAD's Avatar
Member
Thread Starter
Join Date: Jul 2006
Location: usa
Posts: 81
onan generator no output

can anyone tell me where or what to look for. the engine runs good and I have tried the flash field test and nothing happens. I feel current on the drill that I have connected ,but it seems that it is not enough to turn it on.
 
Sponsored Links
  #2  
Old 09-26-08, 12:02 PM
Member
Join Date: May 2008
Location: Lady Lake Florida
Posts: 105
if you can, look on the id tag and post the model/spec #. please
 
  #3  
Old 09-26-08, 04:58 PM
NAVYDAD's Avatar
Member
Thread Starter
Join Date: Jul 2006
Location: usa
Posts: 81
Post

liljman,I'LL get it for you I'm sorry about that, it's that I really want to make this work if I can,I'll post back with the info.
 
  #4  
Old 09-29-08, 11:35 AM
NAVYDAD's Avatar
Member
Thread Starter
Join Date: Jul 2006
Location: usa
Posts: 81
liljman,Here is the model info ONAN K2200 MODEL=2.2KM-1P/1B POWER EXPRESS pelase help
 
  #5  
Old 09-29-08, 12:36 PM
Speedwrench's Avatar
Member
Join Date: Apr 2008
Location: Oklahoma
Posts: 1,698
navydad have you used a voltmeter on any of the outlets yet?

murphy was an optimist
 
  #6  
Old 09-29-08, 12:49 PM
Member
Join Date: Dec 2006
Location: usa
Posts: 1,365
Originally Posted by NAVYDAD View Post
can anyone tell me where or what to look for. the engine runs good and I have tried the flash field test and nothing happens. I feel current on the drill that I have connected ,but it seems that it is not enough to turn it on.
have you tryed other items or tested the drill on a working outlet. maybe the drill is bad.
 
  #7  
Old 09-29-08, 06:05 PM
NAVYDAD's Avatar
Member
Thread Starter
Join Date: Jul 2006
Location: usa
Posts: 81
Question

speeedwrench, I'll try the voltmeter and see what I get off it .and also flirty1 the drill does work I tried it on a house socket.it has a trip switch and other breaker attachments.Do you know where I could try to check for current on a good starting point and catch the problem half way.
 
  #8  
Old 09-29-08, 06:35 PM
Speedwrench's Avatar
Member
Join Date: Apr 2008
Location: Oklahoma
Posts: 1,698
i just use the voltmeter in the outlets to check for correct voltage, i am not sure but your gen might have brushes, if so you might need to check that they are free to move in the holders and not worn out. you can clean with spray electrical contact cleaner to help free them up if they are sticking in the holders.

if we're not supposed to eat animals why are they made out of meat?
 
  #9  
Old 09-30-08, 06:38 AM
NAVYDAD's Avatar
Member
Thread Starter
Join Date: Jul 2006
Location: usa
Posts: 81
speedwrench ,Do I open the housing where the coils are at to get to the brushes?The heart of the generator?Can I unbolt it and remove the guts out to expose the brushes?
 
  #10  
Old 09-30-08, 08:37 AM
Member
Join Date: May 2008
Location: Lady Lake Florida
Posts: 105
navydad, sorry so-long to get back to you, I have a complete library of onan service manuals and would love to help you out, however I find nothing on the info that you have given me...
it could be anything from bad brushes, commutator, or something as simple as a circuit board replacement.
is this a portable unit? rv-genset?,
example mod & spec # NHD, NH, BGM, CCK,. if you can find something similar on your id tag I'll help ya any way I can...

good luck and have a great day
 
  #11  
Old 09-30-08, 09:21 AM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 20,977
hey liljman...does this help you find anything to help NAVYDAD?

Just take a look at the link.

http://cgi.ebay.com/ONAN-K2200-GENER...ayphotohosting
 
  #12  
Old 09-30-08, 10:46 AM
NAVYDAD's Avatar
Member
Thread Starter
Join Date: Jul 2006
Location: usa
Posts: 81
liljman,Tell Me what info You need and i'll look for it on the generator and Yes it is a portable generator with a kohler engine.Also thank Gunguy45 for the help
 
  #13  
Old 10-12-08, 08:54 AM
NAVYDAD's Avatar
Member
Thread Starter
Join Date: Jul 2006
Location: usa
Posts: 81
Question

ok , I finally had some time to mess with the generator,And I turned on the engine and found out I have 12.5 volts coming out of the socket.Not enough to turn anything on .I also found it does have brushes .They are not to bad ,some formation to the direction it is turning.I also as the engine is running I have the volt meter connected and I switch the circuit breaker to the off postion and it drops to 1.5 from the socket reading.liljman, I found this #'s on the generator side model# NA18E1 also NO#3IM017 PLEASE HELP
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes