snapper SR1433 rider

Reply

  #1  
Old 10-04-08, 09:14 AM
Member
Thread Starter
Join Date: Oct 2008
Location: south florida
Posts: 1
snapper SR1433 rider

i have a snapper SR1433 rear engine rider. runs great since i replaced the carb. i now have another problem,when going in straight line the mower seems to pull ok,then pops and jumps. if i turn either way left or right,the rear end pops and stops pulling then starts pulling again. i have replaced the clutch,clutch drive and washer. sounds like axle may be popping is the best noise i can describe to you. i have the mower jacked up and wheels off the ground and when i turn the right rear wheel,it turns for 180 degrees then catches like it ready to pull.

any suggestions or ideas for me?

thanks
 
Sponsored Links
  #2  
Old 10-04-08, 09:29 PM
30yearTech's Avatar
Member
Join Date: Oct 2006
Location: Central Texas
Posts: 1,176
May have an issue with the differential gears broken or binding. When you rotate one of the tires, does the other side rotate in the opposite direction??
 
  #3  
Old 10-04-08, 09:46 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,817
I agree... something going bad in the rear end. It's a good chance it's the chain jumping.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes