MTD Lawn tractor

Reply

  #1  
Old 10-07-08, 12:49 PM
Member
Thread Starter
Join Date: Aug 2008
Location: MO.
Posts: 39
MTD Lawn tractor

I have a MTD lawn tractor with Briggs and Stratton 422707-1214-01. I rebuilt the carb on this thing and it wants to run at full speed. I've backed the idle screw out almost all of the way and still full speed. I can put the choke at 3/4 to half and it will idle down and let me change speeds. Is the carb the problem or maybe the linkage somewhere else. Thanks in advance.
 
Sponsored Links
  #2  
Old 10-07-08, 02:06 PM
30yearTech's Avatar
Member
Join Date: Oct 2006
Location: Central Texas
Posts: 1,176
The problem could be in the linkages, or the governor may need to be adjusted.
 
  #3  
Old 10-08-08, 06:11 AM
Member
Thread Starter
Join Date: Aug 2008
Location: MO.
Posts: 39
Thanks 30year for the speedy response!! I just noticed that there is a small amount of gas that spatters up from the intake as well. Before I start tearing apart the linkages and reinstalling should I tear the carb apart one more time to make sure everything is sealed properly? I have never had this much trouble from a carb rebuild.

Thanks
 
  #4  
Old 10-08-08, 10:47 AM
30yearTech's Avatar
Member
Join Date: Oct 2006
Location: Central Texas
Posts: 1,176
A little blow back is not that unusual and could indicate some issues with your valves. Since it does start and run, I would not be concerned about the blow back at this time. I still think the problem is in the linkage hook up to the carburetor or your governor adjustments.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes