Ariens z-turn again

Reply

  #1  
Old 11-11-08, 12:53 PM
Member
Thread Starter
Join Date: Jul 2006
Location: Central New Hampshire
Posts: 754
Ariens z-turn again

Same problem with the Ariens Zero turn mower.
Arien #915037-00015 B&S# 31H777-0110-E1
Problem: blows oil from fuel pump hose.
Oil level is at full mark.(5W30 per Ariens temp recomendation)
Changed fuel pump.
Air filter is clean.
I am thinking the breather filter could have something to do with this. Haven't looked at it yet as the flywheel needs to be pulled to repalce it.
Any suggestions?
Thanks.
 
Sponsored Links
  #2  
Old 11-11-08, 04:23 PM
30yearTech's Avatar
Member
Join Date: Oct 2006
Location: Central Texas
Posts: 1,176
What do you mean "it blows oil from the fuel pump hose"

Are you talking about the pulse hose to the fuel pump?? There will be some oil present in this line, if it's leaking, then the hose may be bad.
 
  #3  
Old 11-12-08, 11:39 AM
Member
Thread Starter
Join Date: Jul 2006
Location: Central New Hampshire
Posts: 754
Found the leak. First I replaced the spring clamp with a screw clamp on the impulse line. That slowed it down a lot. I had previously replaced the fuel pump with a brand new one. It appears now that it is leaking oil out of the center (vent?) hole in the pump. There is also a hole off to the edge of the pump that has a brass screen in it. It is NOT leaking there.
Why would the impulse side of the pump be sucking up oil?
 
  #4  
Old 11-12-08, 02:43 PM
30yearTech's Avatar
Member
Join Date: Oct 2006
Location: Central Texas
Posts: 1,176
I would think that the pump is bad, it should not leak oil out of the pump.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes