Ariens 8526 snowblower over speed

Reply

  #1  
Old 11-29-08, 05:55 PM
Member
Thread Starter
Join Date: Aug 2006
Posts: 4
Ariens 8526 snowblower over speed

Hi,

I was prepping my 4 year old snowblower for the winter by changing the engine oil, refilling with gas, and starting it. When I started it, the engine seemed to be running way too fast, to the point where I was worried the engine would destroy itself. The throttle control lever has no effect on engine speed until it is on minimum speed when the engine almost stalls. Any ideas?
 
Sponsored Links
  #2  
Old 11-29-08, 07:45 PM
Member
Join Date: Dec 2006
Location: usa
Posts: 1,365
sounds like the governor is broken or a cable broke. did you remove anything or break anything while changing the oil.
 
  #3  
Old 11-30-08, 05:27 AM
Member
Join Date: Jul 2006
Location: Central New Hampshire
Posts: 754
check the kinkages and make sure the throttle on the carb moves freely.
 
  #4  
Old 11-30-08, 08:45 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,822
I agree that the throttle is probably stuck. Old gas gums up the shaft and most likely a bit of carb cleaner sprayed at the shaft and a little persuasion back and forth will free it up.
 
  #5  
Old 12-01-08, 06:42 AM
Member
Thread Starter
Join Date: Aug 2006
Posts: 4
Thanks for the suggestions. I'll get some carb cleaner and try to clean things up. Hopefully it is as simple as that.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes