Poulan saw wont keep running

Reply

  #1  
Old 12-07-08, 08:48 AM
Member
Thread Starter
Join Date: Dec 2008
Location: california
Posts: 1
Poulan saw wont keep running

I have a Poulan 2050 chain saw that starts on starter flood so its a fuel problem. I replaced all fuel lines and the primer bulb and it ran good for about one hour.Next day the truble started. All screw are tight, all hoses on good, plug is clean. The store sold me a used primer bulb and I think the check valve in the primer bulb is not working but I dont know if it matters once its running. I do see air in the primer hose going the carb. but no air in the fuel line from the tank to the carb. Some times it will run in full choke for about 15-30 sec Ive removed the carb and check evey thing. Dose the primer bulb have to be working to run? any other ideas thanks Don
 
Sponsored Links
  #2  
Old 12-07-08, 09:34 AM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,728
It doesn't have to be working (as in being able to prime the engine), but it can't be leaking = flooding engine or entraining air into the fuel delivery.
 
  #3  
Old 12-07-08, 03:29 PM
30yearTech's Avatar
Member
Join Date: Oct 2006
Location: Central Texas
Posts: 1,176
Sounds like the trouble may be in your carburetor. I would pull the pump cover off the carburetor and check the filter screen in it, possible build up on it.
 
  #4  
Old 12-08-08, 03:55 AM
Member
Join Date: Nov 2005
Location: North Carolina
Posts: 948
agree with 30yearTech. my echo primer cracked on a saturday and i was able to use the saw all weekend with no problems. flooding could be from a misadjusted fulcrum lever in the carb or a carb that's just plain bad.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes