Homelite LRI 4400 Generator

Reply

  #1  
Old 12-23-08, 05:46 AM
Member
Thread Starter
Join Date: Dec 2008
Posts: 2
Homelite LRI 4400 Generator

I changed the oil in my Homelite generator last night after letting it run for a few minutes. Afterwards, I seem to have lost the spark and now it will not start. I tipped it to about 45 degrees when I was working on it. Does it have a safety switch somewhere? I do not have a manual and would appreciate any help I can get.
Thanks.
 
Sponsored Links
  #2  
Old 12-23-08, 05:52 AM
30yearTech's Avatar
Member
Join Date: Oct 2006
Location: Central Texas
Posts: 1,176
Are you sure the oil is filled to the proper level?

There may be a low oil cut off switch and if level is too low it would shut down the spark. There is also a possibility that if equipped with a low oil switch, it may not be working properly.

If you can post the brand model and spec numbers from the engine, we may be able to advise better.

Best of Luck...
 
  #3  
Old 12-23-08, 06:18 AM
Member
Thread Starter
Join Date: Dec 2008
Posts: 2
Generator

Thanks for the quick reply. Without the manual I wasn't sure how much oil to put in, so I put in what I took out. About 1-1/4 qts.

I'll get the numbers tonight and post them here.

Again, thanks for your help.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes