B&S 6hp stalls

Reply

  #1  
Old 01-02-09, 12:47 PM
Member
Thread Starter
Join Date: Jan 2009
Location: eastern massachusetts
Posts: 1
B&S 6hp stalls

Hi guys,
new to the forum and was wondering if anyone could help with a problem I am having.
I have a Briggs and Stratton 6hp engine on my log splitter. It starts fine but stalls unless I hold in the primer bulb.
Any advice?
 
Sponsored Links
  #2  
Old 01-02-09, 01:24 PM
Member
Join Date: Dec 2008
Location: Carleton Place
Posts: 156
It's not getting gas, has the carb ever been serviced?
 
  #3  
Old 01-02-09, 01:25 PM
Member
Join Date: Jul 2006
Location: Central New Hampshire
Posts: 754
Sounds like the carb needs to be taken off, soaked in a carb cleaning solution, then re-assembled with ne parts.
 
  #4  
Old 01-02-09, 03:37 PM
Member
Join Date: Jun 2006
Location: St. Louis
Posts: 2,365
First, Welcome to the Forum;
Please post the engine model, type and code numbers usually found on the engine shroud just above the spark plug or on a tag above the muffler. We can then find what carb you have and give better assistance. Have a good one. Geo
 
  #5  
Old 01-03-09, 12:59 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
That sounds like a classic problem that fits tecumseh engines. Are you sure it's a Briggs? Model numbers would help as Geogrubb suggested.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes