Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Craftsman Snowblower Problems


jam3000's Avatar
Member

Join Date: Nov 2006
Posts: 15
MI

01-04-09, 10:56 AM   #1  
Craftsman Snowblower Problems

I am having problems with Craftsman snowblower model # 247-886640. 5hp 24".

I had trouble with the following:
1. Would only run at half choke.
2. Bogs down under small snow load.
3. Smelled very rich. fumes.

I took bowl off and cleaned the small hole on the bolt. Put back on. Did not make much difference. Took to a guy who cleaned the carb and adjusted. Idles much higher. Maybe too high. Will run on no choke now and does not smell as bad.

Still does not seem to be running the best it should. Still bogs down under load. Not as bad as before cleaning and adjustment. Seems as if it should throw more snow.

Anything else I can do? I live in the U.P. of Michigan. Spring is a long ways away.....

Carb kit? Where can I find the engine numbers? Under the little black box covering the carb. I think the engine is a Tecumsa

 
Sponsored Links
smallengineguy's Avatar
Member

Join Date: Jan 2007
Posts: 514
MA

01-04-09, 12:12 PM   #2  
Sounds like a carb problem. engine numbers are stamped into the housing near spark plug or on a tag on the carb side of the housing. If you have electric start the numbers may be under the receptacle. post the numbers and we can give the PN# for the carb kit

 
Search this Thread