Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

yard machine auger problem


bassman763's Avatar
Member

Join Date: Jan 2009
Posts: 5

01-04-09, 04:18 PM   #1  
yard machine auger problem

Someone please help.
i hit a rock with my snow king and the auger and impellar quit working, i checked the 2 sheer pins on the auger axle and there in place.i can turn the impellar buy hand and it turns the auger also. is there a belt or have i messed up a gear or something and if so is this hard to fix.thankxx

 
Sponsored Links
cpgixxer's Avatar
Member

Join Date: Dec 2008
Posts: 156

01-04-09, 04:22 PM   #2  
If you can turn the impeller and the auger blades turn then the gears are working, this is good news. Take off the plastic belt cover and look at your shredded belt(s), I did the 2 years ago when I hit a gas meter, not fun.

 
bassman763's Avatar
Member

Join Date: Jan 2009
Posts: 5

01-04-09, 04:28 PM   #3  
belt

so is this considered a 2 stage snowblower when the auger drive and wheels are controlled seperate and is there a internal gear box or just a belt because i did not see a belt cover? thanks


Last edited by bassman763; 01-04-09 at 04:33 PM. Reason: wrong question
 
cpgixxer's Avatar
Member

Join Date: Dec 2008
Posts: 156

01-04-09, 04:33 PM   #4  
Well I'm taking a guess that there is, you mention impeller and auger which indicates it's a 2 stage machine. There may be 1 or 2 belts which drive the auger, there should be a plastic cover held on with a couple of bolts that cover the belts and pulleys.

 
bassman763's Avatar
Member

Join Date: Jan 2009
Posts: 5

01-04-09, 04:42 PM   #5  
thanks

thanks i'll try this tomorro, i'm new to this site and appreciate your help.....

 
Search this Thread